Benutzer-Werkzeuge

Webseiten-Werkzeuge


lager:lok_netze:ospflabor_mikrotik

Praktische Übung – dynamisches Routing mit dem Open Shortest Path First (OSPF) mit MikroTik/RouterOS

IN PROGRESS

Überblick

HINWEIS: Bevor die Übung begonnen wird, sollte der Mikrotik-Router in Ausgangszustand zurückgesetzt werden, damit keine alten Konfigurationen stören. Die Vorgehensweise wird hier beschrieben:

Mikrotik-Router zurücksetzen.

Szenario

Grundnetz

Grundkonfiguration

# IP-Adressen setzen letztes Oktett entspricht der Router Nummer. Hier R2
/ip address
add address=10.0.1.2/24 interface=ether2 network=10.0.1.0
add address=10.0.2.2/24 interface=ether3 network=10.0.2.0

# Aktiv den router-id setzen. Hier: router-id=2.2.2.2 das R2
/routing ospf instance
set [ find default=yes ] router-id=2.2.2.2

# OSPF auf den neuen Netzen aktiven.
/routing ospf network
add area=backbone network=10.0.1.0/24
add area=backbone network=10.0.2.0/24

# Überprüfen, welche Nachbarn existieren
/routing ospf neighbor print

Kosten auf den Interfaces ändern

Zunächst sollte man sich einen Überblick über die aktuelle OSPF-Interface-Konfiguration verschaffen. Folgender Befehl zeigt diese an.

# Interface Konfiguration anzeigen
/routing ospf interface print

# Ausgabe:
Flags: X - disabled, I - inactive, D - dynamic, P - passive 
 #    INTERFACE                        COST PRIORITY NETWORK-TYPE   AUTHENTICATION AUTHENTICATION-KEY
 0    ether3                            100        1 broadcast      none                             
 1 D  ether2                             10        1 broadcast      none 

Am D kann man erkennen, dass das Interface mit der Nr 1 dynamisch ist. Hier sind die Kosten auf dem Default-Wert von 10.

Diese können auch bei dynamischen Interfaces nicht geändert werden. Erst nachdem man aus dem dynamischen Interface ein statisches (ohne D) konfiguriert, kann man aktiv Kosten setzen.

Interface statisch machen und Ändern der Kosten

Zunächst muss das bereits unter IP angelegte interface unter OSPF bekannt gemacht werden.

HINWEIS: Dynamischen Interfaces (mit D gekennzeichnet) können unter OSPF keine Kosten zugewiesen werden.

# Aus dynamischen interface statische im OSPF machen
/routing ospf interface add copy-from=0
/routing ospf interface add copy-from=1

# Kosten setzen hier auf den oben übernommen interfaces 0 und 1
/routing ospf interface set 0 cost=100
/routing ospf interface set 1 cost=100

Routenaggregation in OSPF

Als Routenaggregation bezeichnet man das Zusammenfassen von vielen einzelnen Routen zu wenige Routen. Im obigen Beispiel können die vier 10.0.0.0/24er Netze in ein 10.0.0.0/16er Netz zusammengefasst werden. Für den Verbindungs-Router (unten) spielen damit die einzelnen Netze keine Rolle mehr. Das obige Beispiel wird um einen zweiten Ring RING 2 erweitert. Die beiden Ringe werden als area miteinander verbunden. Das folgende Bild zeigt dies. Die grundsätzlichen Befehle finden sich darunter.

Zwei Ringe verbunden

Auf Router 3 des Backbones (RING 1) werden die Routen für 10.0.0.0/16 aggregiert, statt fünf einzelner /24er Netze. Das selbe wird für das 20.0.0.0/16 (RING 2) durchgeführt.

/routing ospf area range add area=Ring2 range=20.0.0.0/16
/routing ospf area range add area=backbone range=10.0.0.0/16

Wireshark-Beispiel Mitschnitt von OSPF

In der folgenden Datei ist ein Trace mit einer Area in der fünf Router konfiguriert wurden aufgezeichnet worden. Die Datei muss entpackt werden und kann dann im wireshark geöffnet werden.

ospf.ringmit5routern.pcapng.zip

Ergänzungen

richard, 01.02.2019 16:09

/ip address wurde ergänzt. Danke. Alternativ kann das /ip address vor jede Zeile geschrieben werden.

test213.61.187.98, 29.01.2019 08:34

Um die Adressen hinzuzufügen, ist die Syntax falsch. Es muss „/ip address add address=“ heißen.

Geben Sie Ihren Kommentar ein. Wiki-Syntax ist zugelassen:
A G U T W
 
lager/lok_netze/ospflabor_mikrotik.txt · Zuletzt geändert: 18.02.2019 17:33 von richard