Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/WH49045962/wwwroot/inc/parser/handler.php on line 1552 lager:lok_netze:mt_ipv4staticroute [Kopfload.de - Lad Dein Hirn auf!]

Benutzer-Werkzeuge

Webseiten-Werkzeuge


lager:lok_netze:mt_ipv4staticroute

Praktische Übung – statisches Routing mit MikroTik/RouterOS

HINWEIS: Bevor die Übung begonnen wird, sollte der Mikrotik-Router in Ausgangszustand zurückgesetzt werden, damit keine alten Konfigurationen stören. Die Vorgehensweise wird hier beschrieben:

Mikrotik-Router zurücksetzen.

Szenariobeschreibung #1

In dieser praktischen Übung sollen Sie ein Netzwerk erstellen, in dem Pakete anhand von statischen Routen weitergeleitet werden.

Szenario #1

Bilden Sie dazu x Gruppen. Jede Gruppe verwaltet einen Router und mind. einen Client. Planen Sie (gerne im Klassenverbund) das Szenarios bevor Sie versuchen es durchzuführen!

Jede Gruppe betreibt einen Router und mind. einen Client (beides Ubuntu-Betriebssysteme).

Konfiguration der Clients

Der Client ist direkt an den Router über dessen Schnittstelle ether6 angeschlossen.

Gelbes Kabel des Clients = Netzwerk der Gruppe – IP-Adresse 192.168.X.100+Platznummer/24

Vergessen Sie nicht den Eintrag eines Standardgateways beim Client.

HINWEIS: Die Clients haben standarmäßig den raumserver als Standard-Gateway konfiguriert (s. route -n). Im Netzwerkmanager ist ein Eintrag raumnetzwerk ohne gateway angelegt, der dieses Gateway entfernt. Überlegen Sie sich, warum Sie diesen Eintrag verwenden sollten!

Konfiguration der Router

Der Router wird auf zwei Schnittstellen konfiguriert. Verbinden Sie sich zur Konfiguration mit telnet mit dem Router auf ether1 (z.B. telnet 192.168.65.80). Die Geräte sind mit den jeweiligen IP-Adressen beschriftet.

ACHTUNG: Die IP-Adresse auf der Schnittstelle ether1 sollte nicht geändert werden, damit ein Zugriff auf die Geräte möglich bleibt. Die IP-Adressen sind ausschließlich auf ether1 konfiguriert!

Verwenden Sie den Benutzer schueler (ohne Passwort).

Schnittstelle ether2 = gemeinsames Routernetzwerk – IP-Adresse 10.0.0.X1/8

Schnittstelle ether6 = Netzwerk der Gruppe – IP-Adresse 192.168.X.1/24

Konfiguration einer Schnittstelle – Beispiel:

# weist der Schnittstelle ether2 die IP-Adresse 10.1.1.2/24 zu.
/ip address add address=10.1.1.2/24 interface=ether2 

# legt eine Route in das Netzwerk 192.168.2.0/24 an. 
# Der nächste Router ist hier mit 172.16.1.2 angegeben.
/ip route add dst-address=192.168.2.0/24 gateway=172.16.1.2  

# zeigt die vergebenen IP-Adressen an.
/ip address print 

Szenariobeschreibung #2

Im zweiten Szenario sind die Router der Gruppen hintereinander angeschlossen.

Konfiguration:

Jeder Router einer Gruppe ist Mitglied in zwei Netzwerken. Mit dem einen Interface hängt er im Netzwerk der eigenen Gruppe, mit dem anderen Interface im Netzwerk der nächsten Gruppe.

Im eigenen Netzwerk (gelbes Kabel) hat er die IP-Adresse 192.168.X.1/24

Im Netzwerk der nächsten Gruppe (blaues Kabel) hat er die IP-Adresse 192.168.X+1.2/24

Die letzte Gruppe (z.B. Gruppe 12) schließt sich mit einem Interface an das Netzwerk der Gruppe 1 an. Hier hat der Router entsprechend die IP-Adresse 192.168.1.2/24

Auf dem Router muss nun in jedes Zielnetz (also die Netzwerke der andere Gruppen) eine Route eingetragen werden oder arbeiten Sie mit der default-Route.

Beispiel:

Der Befehl /ip route add gateway=10.1.1.1 fügt einem Router eine default-Route hinzu. Alle Pakete für die es keine explizite Route gibt, werden an den Router mit der IP-Adresse 10.1.1.1 weitergeleitet.

TIPP: Vermeiden Sie durch sorgfältige Planung (mit der gesamten Klasse) Routing-Schleifen!

Ziel: Jeder Client kann aus allen anderen Gruppennetzwerken einen Client mittels ping erreichen.

Ergänzungen

richard, 31.10.2018 08:56

route und print ergänzt

fi7b, 30.10.2018 09:27

verbesserung: /ip route add dst-address=192.168.2.0/24 gateway=172.16.1.2

test213.61.187.98, 30.10.2018 09:21

/IP print wird vom Mikrotik-System als ungültiger Befehl zurückgegeben. Ist /IP address print gemeint?

Geben Sie Ihren Kommentar ein. Wiki-Syntax ist zugelassen:
Y Y Z G J
 
lager/lok_netze/mt_ipv4staticroute.txt · Zuletzt geändert: 05.12.2018 12:32 von richard